May 5, 2012
36
1
Calgary
VetteCoins
605
Car
1979
Hi Lads: I changed out the rad this year, but the fan stuck to the front of the engine is something I'd like to replace. Have you installed an electric fan unit? I'm thinking of a two fan unit to improve cooling as when I crank the car to 180 km's or so the temp tends to stay pretty hot for the rest of the ride.

Any experiences or suggestions you'd like to share would be very much appreciated. Thanks!
 
  • Like
Reactions: 72ray
Hi Lads: I changed out the rad this year, but the fan stuck to the front of the engine is something I'd like to replace. Have you installed an electric fan unit? I'm thinking of a two fan unit to improve cooling as when I crank the car to 180 km's or so the temp tends to stay pretty hot for the rest of the ride.

Any experiences or suggestions you'd like to share would be very much appreciated. Thanks!

A single fan with temp control is all youi need :D
 
I was running a single fan and it worked great. It is/was a Be Cool 16". I wired in an override so I could run it whenever I wanted but you don't need to. They do draw some power though and you may notice that is surges while you are signaling and the headlights are on. But it worked great!

T
 
I run a high flow water pump with the 7 blade AC fan, 4 core rad with water wetter. Temp never gets above 200 on the hottest days, most highway runs it's around 195.
 
  • Like
Reactions: 72ray
Old Thread: Hello . There have been no replies in this thread for 100 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Users who are viewing this thread