clock not working c6

Shayne

Regular
Dec 1, 2010
439
27
Awards
3
moose jaw,sask.
0
VetteCoins
202
Car
2005 convertible
Province / State
Saskatchewan
  • SK
  • You're 5
  • You're a Regular
i can't seem to set the clock on my 05. it has nav. i've followed the directions but no luck, it wll not adjust when i get to the clock adjust menu. i think the nav/radio was pulled for an aftermarket system and reinstalled. would the clock be affected by the gps wires possibly not being plugged in properly or at all? any assitance would be great.
 

Shayne

Regular
Dec 1, 2010
439
27
Awards
3
moose jaw,sask.
0
VetteCoins
202
Car
2005 convertible
Province / State
Saskatchewan
  • SK
  • You're 5
  • You're a Regular
just went out to the garage and noticed the gps indicator has a red line thru it. so i take it there is no gps wire plugged in.
 

Riley P

Staff member
Moderator
Power User
Jan 11, 2009
10,831
1,605
Awards
7
Saska-ba-toon!
0
VetteCoins
5,007
Car
2000 Z51
Province / State
Saskatchewan
  • C5
  • SK
  • You're 5
  • 10 Years
  • You're a Regular
  • King of the Post
A good person to call and ask questions about your car or visit locally is Russ K. He runs Auto Lab in Regina and is a Corvette enthusiast. I had him do a light tune to my car and he was very good to talk with.

You can of course talk to Manny as he knows these cars inside-out, but if you would like to see someone, I recommend seeing Russ.
 

07silvervette17

Active Member
Feb 24, 2009
157
9
Awards
3
bc canada
0
VetteCoins
270
Car
corvette silver c6
  • 10 Years
  • You're 5
  • You're a Regular
it is just not picking up gps signal because 3 satellite signals have not been located.Also the gps takes time to locate if you had the battery unhooked for any reason. Do you have a nav manual? It also shows in it how to set the clock manually
 

Shayne

Regular
Dec 1, 2010
439
27
Awards
3
moose jaw,sask.
0
VetteCoins
202
Car
2005 convertible
Province / State
Saskatchewan
  • SK
  • You're 5
  • You're a Regular
i downloaded a manual. still can"t seem to get it working. i suspect that the system was pulled for an aftermarket stereo at some point as i found aa amp in the trunk in 1 of the corner pockets and it has a couple aftermarket speakers in the car. i wondered if the gps wire is maybe unplugged from the back of the unit and if it has any effect on the clock. the clock inst. seem pretty straightforward to me.
 

Ken777

New Poster
Apr 21, 2019
5
10
Awards
1
0
VetteCoins
143
Car
Corvette 2005 C6
Province / State
USA
  • USA
i can't seem to set the clock on my 05. it has nav. i've followed the directions but no luck, it wll not adjust when i get to the clock adjust menu. i think the nav/radio was pulled for an aftermarket system and reinstalled. would the clock be affected by the gps wires possibly not being plugged in properly or at all? any assitance would be great.
I had my 05 C6 into the dealer for the check engine light remaining on and they fixed that but now my clock display is blank and Yhe buttons for setting the clock manually do not respond to the touch. My Caravan bud took his 06 C6 in this week for shock replacement, and his clock display is now blank with inop controls also! The dealer told him several others have had the same problem after service-mainly removing and reinstalling the battery-and they have no idea what is causing it! I had a reauthorizing signal sent by Sirius/XM, no help. I also have had the red line through the GPS when it would normally not be there...curious and frustrating.
 

Rruuff Day

Never wrestle with a pig.
Staff member
Moderator
Power User
Beta
Aug 30, 2014
7,397
7,299
Awards
10
Pine Lake, Alberta
0
VetteCoins
628
Car
C7 3LT ZF1
Province / State
Alberta
  • You're 5
  • C7
  • Alberta
  • You're Celebrated
  • Show Off
  • Hot Chili
I had my 05 C6 into the dealer for the check engine light remaining on and they fixed that but now my clock display is blank and Yhe buttons for setting the clock manually do not respond to the touch. My Caravan bud took his 06 C6 in this week for shock replacement, and his clock display is now blank with inop controls also! The dealer told him several others have had the same problem after service-mainly removing and reinstalling the battery-and they have no idea what is causing it! I had a reauthorizing signal sent by Sirius/XM, no help. I also have had the red line through the GPS when it would normally not be there...curious and frustrating.
Seems to be getting to be a very common with C6's lately. I would have expected GM to have come out with a tech bulletin warning dealers not to disconnect the battery without a backup power supply to the clock display. At least until they figure out why it's crashing. Strangely enough, I had to change the battery on my 09 C6 a few years back. Did it myself and had no problems with clock display. I wonder if it has to be disconnected for some period of time before the clock will not re-boot...
 

Area Z51

Regular
Nov 12, 2009
257
114
Awards
6
New Brunswick
0
VetteCoins
1,895
Car
2006 C6
  • You're Liked
  • You're Celebrated
  • 10 Years
  • C6
  • You're 5
  • You're a Regular
Seems to be getting to be a very common with C6's lately. I would have expected GM to have come out with a tech bulletin warning dealers not to disconnect the battery without a backup power supply to the clock display. At least until they figure out why it's crashing. Strangely enough, I had to change the battery on my 09 C6 a few years back. Did it myself and had no problems with clock display. I wonder if it has to be disconnected for some period of time before the clock will not re-boot...
This only started happening in late 2018. Prior to that, the battery disconnection had no ill effects on the Nav Clock
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)