blue_bomber697

blue_bomber697

Regular
Oct 20, 2013
345
13
Fort McMurray, AB
VetteCoins
575
Car
2014 Z51
kH5EAWll.jpg


Went out for a nice cruise with my buddy today. Still a bit of water on the roads in some areas but I just couldn't resist. The car is mostly covered with XPEL so I wasn't too worried. Got did I miss the feeling this car gave me. Went to the gym first in it and I was shaking walking in there still. :)
 
kH5EAWll.jpg


Went out for a nice cruise with my buddy today. Still a bit of water on the roads in some areas but I just couldn't resist. The car is mostly covered with XPEL so I wasn't too worried. Got did I miss the feeling this car gave me. Went to the gym first in it and I was shaking walking in there still. :)

Rained in Winnipeg today and roads all still covered in sand from winter, maybe in a week or two we will get back on the road. Enjoy your ride and see in in Spring Mountain in July
 
I am envious! I am so itching to get my car on the road. I have a Canadian Council of Corvette Clubs meeting in Mississauga on the 18th. I sure hope I can drive it there. I got my C7 on January 20th. It still has 4 klicks on the clock. [Sigh] But I talk to it every day. I have driven the car about 4 feet in the last two months as I occasionally reposition the tires.

I am hoping for some April showers to wash away the salt, brine an sand before I take her out on the road. It sits in the garage while the cold weather taunts and tortures me. Grrr.
 
I'm not sure I can wait much longer for the rain to wash the salt and brine away.

I'm thinking I may have to get her out on Thursday since the temps are supposed to spike up to 18C then 15 on Friday. Warm enough that I'll be able to give her a good wash afterwards.
 
Yeah. I finally got to scratch my 6 month long itch. But now it's getting put away again for another week or so. Yesterday was +11 and sunny, the next week is around +4, lots of rain, and we are supposed to get 5cm of snow tonight! :'(
 
She arrived safe and sound. Thanks Manny. :)
 

Attachments

  • IMG_0514.jpg
    IMG_0514.jpg
    58.9 KB · Views: 24
  • IMG_0510.jpg
    IMG_0510.jpg
    60 KB · Views: 23
Had mine out today, sunny 50F. The car was stored since mid Nov in a unheated attached garage, only rolled the tires once about 2 weeks ago. Put 40 lbs of air in them before putting away, filled the gas tank, washed the car and put the cover on. Happy to report the tires ran smooth right from the get go , no issues with the car at all, no flat spotted tires. The tires sat on bare dry concrete for 5.5 months, the summer only Michelins seem unaffected so all the worry on the threads about these tires seems for not.

One thing I did notice is that after disconnecting the battery for 2.5 months (while we were in Florida) the car asked me to roll the windows down and back up when I reconnected it. Guess that is to set the limits for when you open and close the doors. Outside of that again no issues with disconnecting the ground on the battery. All the radio settings were maintained. I did put it on a smart charger once reconnected. Happy motoring , spring is here :)
 
Just got back from taking my Z51 out of storage this afternoon. It's been a long 4 months.

Took off her winter cover, took off the battery tender and she fired right up! Checked tire pressure , all good! Checked oil life, 98%, which was strange since a lot of people are reporting that it dropped while stored. Battery fully charged.

Let her warm up and off we went! Was a nice drive back down from Caledon ( where I store it ), then a few runs on the 410.

Boy it's nice to have her home!
 
Was out today, 1st time since I took it home 2 weeks ago, what an awesome ride. Still breaking it in, but the car felt like it was glued to the road.

Don't like the fact that the engine needs to be running to setup the vehicle preferences, such as setting the auto exit..etc. Don't know why they did that. Have been sitting in the garage with the manual playing with the controls then had to start it to go to that menu, you know how loud it is when you start it in the garage?
Pretty damn loud woke up my cat, wife and half the neighbourhood.:D
 
So got in the car today and oil life had dropped to 56%, so reset via the DIC. Besides that all is good, was out driving for an hour today. Feels so good to be back in the saddle!
 
Old Thread: Hello . There have been no replies in this thread for 100 days.
Content in this thread may no longer be relevant.
Perhaps it would be better to start a new thread instead.

Similar threads

Users who are viewing this thread