LSXtasy

LSXtasy

Power User
Feb 15, 2012
1,391
41
Wellesley,ON
VetteCoins
504
Car
2001 Z06
So I have been having a few electrical gremlins with my C5. One issue is when my lights are on I have to turn on my highbeams to get my headlights to go back down. The other issue, after replacing the left side fuel pump, is an intermittent fuel level gauge issue. I've read up on it and found that the grounds on the front fenders are the most common culprits for weird electrical problems. I disconnected my battery and I'm in the process of cleaning them. I have the grounds themselves soaking in vinegar. I wire brushed them as per recommendation, and then put them back in the container to soak a bit longer. So, my question is....will disconnecting my battery reset my ECU? I just had it tuned and don't want to lose it. My other question is if cleaning the 2 grounds on the fenders doesn't work, what else should I check? The bumber grounds, etc.?. Thanks.

Sent from my SGH-I747M using Tapatalk 2
 
Last edited:
So I have been having a few electrical gremlins with my C5. One issue is when my lights are on I have to turn on my highbeams to get my headlights to go back down. The other issue, after replacing the left side fuel pump, is an intermittent fuel level gauge issue. I've read up on it and found that the grounds on the front fenders are the most common culprits for weird electrical problems. I disconnected my battery and I'm in the process of cleaning them. I have the grounds themselves soaking in vinegar. I wire brushed them as per recommendation, and then put them back in the container to soak a bit longer. So, my question is....will disconnecting my battery reset my ECU? I just had it tuned and don't want to lose it. My other question is if cleaning the 2 grounds on the fenders doesn't work, what else should I check? The bumber grounds, etc.?. Thanks.

Sent from my SGH-I747M using Tapatalk 2
I think you'll end your problems with grounds .What other gremlins are you experiencing other than headlights ?
 
Headlights, and a fuel gauge that will just read empty whether I just filled it or not. It never does it in the same spot. Sometimes it'll do it at half a tank, sometimes 3/4 full, sometimes 3/4 empty.:confused:
I've replaced the L/S fuel pump which are notorious for causing issues. That side has the fuel sending unit, and also replaced the fuel filter which has been known to cause problems.
Sent from my SGH-I747M using Tapatalk 2
 
Awesome! Thanks for the advice and the links, I have read and saved them.
I reassembled the 2 grounds that I took apart and the headlights are the same. When I have a chance I'm going to move on to another ground (by the battery) and see if that helps any.

Sent from my SGH-I747M using Tapatalk 2
 
Awesome! Thanks for the advice and the links, I have read and saved them.
I reassembled the 2 grounds that I took apart and the headlights are the same. When I have a chance I'm going to move on to another ground (by the battery) and see if that helps any.

Sent from my SGH-I747M using Tapatalk 2

Justin: In case you haven't seen this one yet you might find it helpful:

Corvette electrical ground locations and servicing C5 models by froggy - YouTube

Have you got a chart of all the grounding spots on the car?

C.
 
No, I don't have any official service manuals or drawings for where all the grounds are. I just saved the pics from the previous posts on this thread. I'll have tp watch the video when I'm at home Colin. Thanks for posting. Plus, much appreciated if you open that service manual, Elf. Great bunch of guys here.

Sent from my SGH-I747M using Tapatalk 2
 

Similar threads

Users who are viewing this thread