Rowarrior

Regular
Jan 25, 2009
405
0
Awards
3
Saskatoon
VetteCoins
303
Car
1980
Hi guys, couple of days ago I backed up from a parking stall and I heard a "clunk" noise from the steering system around the front wheels as I was turning the steering-wheel in reverse to get out (speed 1 km/h)

Right then I lost the assisted steering (as C3's do not have power steering). Back at home I checked the components (which are: pump/fuild reservoir, belt, hoses, valve and slave cylinder) and I found:

-Reservoir fluid level OK / Pump is quiet
-Belt and belt tension OK
-Hoses look good and tight
-As I revved the motor to assist the pump, the steering did not get better (so may not be the pump?)

I wonder if anyone can give me any advise on this, is it common for the cylinder and or steering valve to fail?

One internet site mentions that little debree can plug the system or the rack could be overpacked with grease? (wouldnt make much sense?)

A curious thing is, those components are 4 years old (5000km old to be exact) and at some point last year the steering made the clunk noise, lost the assisted steering, but it came back few days later...

Help? any pointers? thanks
 

Riley P

Staff member
Moderator
Power User
Jan 11, 2009
11,040
1,919
Awards
8
Saska-ba-toon!
VetteCoins
12,303
Car
2000 Z51
Province
SK
It's probably the Fetzer valve. You'll need to prep it with some 3-in-1 oil and gauze pads then you'll need about ten quarts of anti-freeze, preferably Prestone. No, no make that Quaker State.

It could also be the relief valve in the pump is stuck open.
 
Last edited:

ctdrl-1

Well-Known Member
Jan 12, 2009
521
0
Awards
3
Saskatoon, Sask
VetteCoins
300
It's probably the Fetzer valve. You'll need to prep it with some 3-in-1 oil and gauze pads then you'll need about ten quarts of anti-freeze, preferably Prestone. No, no make that Quaker State.

It could also be the relief valve is stuck in the pump is stuck open.

Thanks for the useless advice Riley!! If you knew anything you would know all that stuff is USELESS without a set of 30 weight ball bearings!:swear:

Brent
 

wildone909

Casual User
Aug 13, 2010
89
7
Awards
3
Port McNeill B.C
VetteCoins
317
Car
1980 , Red ,T.top
Steering system

Hi.. Have you checked the ball stud assembley in the valve on the steering assist ram? If it was loose in the socket it could have popped half way out and not push on the valve to let assist oil into the ram. I let mine go too long with out checking the steering and it almost fell apart.
 

Users who are viewing this thread