L

Lorne Smith

I'm New Here
Jul 19, 2010
5
0
Awards
2
Ontario
VetteCoins
300
Car
1999
I have periodic lights come on showing the abs and anti lock brake's. So far the Chev dealership has put on a new hub and wiring harness. Does anyone have any other ideas Thanks Lorne
 
L

Lorne Smith

I'm New Here
Jul 19, 2010
5
0
Awards
2
Ontario
VetteCoins
300
Car
1999
Sorry new to this

1999 Corvette Conv. The guy I bought it off said it started when he repainted the calipers. Since then 2 hubs were put on with today the garage saying it was in the wiring harness. Well they put a new one on and on the way home the light came on again. They don't know what it is.
 
Riley P

Riley P

Staff member
Power User
Moderator
Jan 11, 2009
11,071
1,952
Awards
8
Saska-ba-toon!
VetteCoins
13,459
Car
2000 Z51
Province
SK
What codes show up on your car? Have you pulled the codes off the DIC yet?
 
HLN A55

HLN A55

High RPM Poster
Jan 27, 2009
2,033
6
Awards
4
Sherwood Park
VetteCoins
425
Car
2001 Z06
i painted my calipers so without issue so I doubt that it was the cause... probably coincidence...
 
Manny@Dasilva

[email protected]

Corvette Specialist
Power User
Feb 5, 2009
3,183
62
Awards
4
Cambridge
VetteCoins
303
Car
1998 C5 / 2015 Z06
Sounds like the ABS unit , it happens a lot with these cars . You will need to have it removed and fixed . Send it to the ABS Fixer . We have done quite a few of these and have had great success with the ABS fixer.

Thx
[email protected]
 
L

Lorne Smith

I'm New Here
Jul 19, 2010
5
0
Awards
2
Ontario
VetteCoins
300
Car
1999
Is the ABS unit part of the main computor. Are we talking major bucks here thanks Lorne
 

Similar threads

Users who are viewing this thread